Skyrim Anniversary Edition

So today we celebrate ten years of Skyrim. I decided to install the Game Pass version even though I have it on disc, but my XSX becomes less silent when a disc is in and it’s not necessary.

But there’s a few things about this. I downloaded it and there is no update for the AE. However when I go into Creation Club the three content pieces ARE free. So is this now the updated version? The main menu doesn’t say AE. It does lag extremely bad for some reason. When I start the game and it shows the main menu with press any button it takes almost a minute to actually do something.

I also noticed that auto HDR and FPS boost are on by default. I probably have the AE now with the enhancements they promised, whatever those really are,I don’t think there are any for XSX. Also took a look at Reddit and some have upgraded to AE and still not see a main menu or even tile change. It’s all a bit unclear right now.


The Game Pass version is the Special Edition. If you want the Anniversary Edition you need to pay for the upgrade.

1 Like

That I know, but I meant the enhancements for SE. You’d think that would require a patch. But it seems they updated the Game Pass version, so once you download that you have the XSX enhancements as well, whatever those are. I don’t think anything has changed. SE already had great loading times thanks to SSD.

Well I just gave Todd Howard my money… Again :sweat_smile:.

To be fair, for £14 it was a bit of a no brainer for me.

1 Like

Tell me how it goes for you because on Reddit I read that for some the game is now broken with the upgrade.

The only new issue I now have with SE is the weird main menu can lag a little.

I haven’t encountered any issues so far. But define broken in this instance?


But also corrupt saves for some. After loading the game with the new upgrade their saves wouldn’t load anymore.

But there’s a but, itss unclear to me if these are modded saves. It should still work, apparently the bad mod news was only for PC but seemingly for some on Xbox too.

With the AE upgrade you get ALL that is in Creation Club?

I haven’t gotten around to playing the game yet, but I did experience the menu lag after it updated/downloaded all the cc items and I restarted the game because it was stuck in an infinite logging in situation.

Yeah it seems better now. Now when I start it up it’s like one or two seconds it briefly stops and then the main menu is fully there.

Although it said it is still down for maintenance, I managed to access the Creation Club and purchase all available Creations. Took me from 5,500 to 250 Credits. The largest credits pack you can buy is 5,500, at $39.99 USD.

— UESP (@UESP_net) November 11, 2021

According to EUSP twitter buying everything new from the creation club will cost about $40 usd. If you haven’t bought anything before it should be around $160 in total.

1 Like

But you get ALL this with the 20 bucks upgrade?

I checked the CC on Xbox and it honestly doesn’t seem to be a ton of content, I reckon it’s much more on pc or nah?

It’s a lot if you don’t care for modding. You also get 10% off if you are Game Pass subscriber. The price should be 18 bucks.


Game is a bit of a mess for me. From how it updates to the fact that when I go into mods it crashes and I need to go back to menu and exit. Also seems to be still running 60fps and HDR mode when they surely should be off.

Auto HDR is disabled? Because I tried running SE without auto HDR and it doesn’t have HDR for me then.60fps is good though?

You bought AE or just playing SE?

I bought AE. I’m not sure where I should be enabling and disabling. I would have expected this to be sorted.

I go into mods and it crashes so I can’t play the game unless l play with mods. An absolute mess.

I don’t think the next Gen upgrade is available yet, at least from the blurb on euro gamer it sounds like the anniversary edition is a new Skyrim bundle and the next ten upgrades will be added to it and special edition later as free upgrade. So far I don’t have the time to test it out, but auto HDR and fpsboost have all been in on in the menus.

Does anybody know if fps boost on does anything now? I turned it off and I swear the game runs at base 60 now

Im on a 1x and own se. Last night way before updating deleted all saves and disabled my mod order, then got the upgrade for 19.00 and updated the game. When i went in dling all those creation clubs it crashed reloaded and let me in cc everything was installed. I started for the time being a vanilla game llol it crashed at door following advar. Started up game and there was tiny update for cc. Reloaded new game, it was wonderful outside cave survival mode option pops up, that was only one lol. Went to bed when reached riverwood. People call cc mods their not their permanent add ons to skyrim they are in vanilla skyrim if you play modless. For mods to work ussep needs for starter to be patched, other mods we have to wait for some may operate once ussep is updated. Ok i think the mod section is disabled atm, i’ve tried several times today. There may be a patch for it cming…ok for 20 dollar upgrade you get all cc content, dont use creation club credits rip off. You guys have no idea how much it adds by thecpics. Your game expands hugely,when mods are fixed you will love it. You should start a new game, i disabled mods. I will start new save with mods when they are fixed most mods need ussep mod to work,i think for that to be fixed the script extender needs fixed don nexus. Itsxreported bethesda gave the extender team the tools a week ago, they bedn working on it.

It sounds like you need to go to the manage game and compatibility options and then disable FPS boost.

These issues you guys are having definitely sucks. I only still have the SE, so I can’t check for you.

But the base SE game from Game Pass with FPS boost disabled runs at 60fps for me. So it seems the upgrade has been applied already.

Maybe it does, I’m currently playing the game with both FPS boost and AutoHDR, and so far no crashes and I was even able to open the mod menu with no trouble. Currently the only thing that’s still a little slow was the start screen. The loading times are the same as before and the game hasn’t asked me to move it to internal as most Next gen enhanced games do. I did go back into the CC menu and got another quick update on some items.

Edit: Ok so I can see the XS enhanced on the picture and apparently it’s currently installed on two different drives, so It’s possible that I’m running it on Internal.