Yakuza 7 stuck on Splash Screen on Series X. Is anybody else having these issues?

Is anybody else having these issues or is it just me?

Its a toss up on if the game will make it past the splash screen when I really want to play it.

2 Likes

I had played 24 hours of Yakuza on my One X before my Series X was delivered. I installed the upgraded version on my Series X and then suffered a major panic when the game would not launch and got stuck on the splash screen every time I tried to run it up.

The good news is that I left it alone and played something else for about 30 minutes and when I went back to Yakuza it had recovered.

I am now 50 hours in and have not had the issue again. Launch day patch installing perhaps?

I had that happen on Series S once. I hard reset my Xbox and then it was fixed.

2 Likes

Same here on an X. I think early on it didn’t have quick resume and now it does? Maybe that’s related if it’s true.

It just doesnt launch if I go to play some other stuff usually.

Yes, and only with Yakuza.

Just had this same issue on the Xbox Series X. I restarted my Xbox and that fixed the problem. Not sure why it’s happening, hopefully they fix it.

Yup. Yakuza seems a bit buggy in general.

1 Like

Arcade is the most buggy for me. Everything else is fine. Playing any arcade game apart from Virtua fighter causes the game to crash.

To be fair I have played over 50 hours of the game and I have not had any other issues.

I keep having to restart the game. Cutscenes continuously bug out and won’t show the prompt to answer someone or continue forward. It’s happened at least three times in my short time with the game unfortunately, on top of the splash screen issue.

Sorry to hear that. Which console are you using? Have you considered reinstalling it?

Series X. I think these issues occur after quick resuming, so I’m just trying to avoid using it. Loving the game otherwise.

I never quick resume Yakuza and have never had an issue like that. It’s possibly related. Only bugs for me is the arcade games that crash the game. It seems to be an issue on PC too.

Actually Quick Resume/Keeping the game running is what has it working for me so I avoid closing it and getting stuck in the splash screen.

Just got stuck loading and had to close the game. Once I rebooted it got stuck on Splash Screen again.

Had to do a full shutdown.

Game crashed my entire Xbox when i booted it up today. That’s a first.