Strange issues with the XboxEra/forum android app

Basically since the first birthday of XboxEra I have been using the app on my phone. I don’t know how I did it, but I think I got a message asking me if I wanted to add it to my home screen and I chose yes.

Ever since then I only had to tap on the XboxEra app on my phone home screen and I was taken directly to the forum, perfect! But lately very strange things have started to occur. The logo of the site started to become smaller and smaller, as if it was zoomed out on daily basis. And loading it up lately takes ridiculously long. Usually when I tapped it, it was one second and I was in the forum. It has a weird delay.

No other apps have this. So I decided to remove it. I went to Chrome, back to XboxEra and I was asked if I wanted to add this site to my home screen. Did that, but it opens the site, not the forum. I always used to check the website via Chrome, but since I visit the forum a lot daily having the app go to the forum was ideal.

Long story short, how do I get that back? Hopefully without the strange issues.


And i just got the message to add the forum to my home screen too and it’s working like day one again.

We’re good!


I had the same issue! Fixed it yesterday.

1 Like

How did you fix it? Did you have to remove the app and reinstall too?

1 Like

Ahhh it’s not just me! I was very tempted to post the same question. If you fix it please let me know how.

EDIT: Just found how to uninstall it, reopened the forum and it let me reinstall it - all seems to be working now.

1 Like

It’s doing it again! :sweat_smile:

1 Like

It’s so damn strange.

I’ve never seen any android app act that way. It’s like it got a life of its own with every day zooming out a little more and becoming a slug to start up.

So far so good here. Also is there a reason why I even need to restart the app so much daily? Why does it close down so soon? Chrome for example keeps running.

It’s, to my knowledge, running a chrome instance, so it should just be the same. Clearly a recent update has caused the behaviour. I’ll post over on the official discourse forums and ask.


What’s the app called? I tried looking in the Play store and couldn’t find it.

It’s not technically an app, it’s more of a chrome add-on.

If you open the forum up on Chrome (on your phone) then click the 3 dots in the top right corner you should have an option to install it.