Can't get the Matrix UE5 demo to run. What's the issue?

For some reason I am unable to play the demo on my XSX. I have uninstalled it and reinstalled it about 4 times and still no go. It loads up through the WB and Unreal Engine 5 screens and then gets stuck on this one. It doesn’t recognise any input from the controller at all. It gets locked into this screen. What am I doing wrong?

Tried to hard reset your console by pushing the xbox button for several seconds? sometimes data in the console cache leads to some unexpected behavior! the reset clears that cache.

Mine was starting from the get go, so it has to be something specific to your console.


Thx, will give it a go when I’m home.

Sounds like some shit I had with that amazing Final Fantasy Souls demo and also the game I am Fish. I had my headset on and powered on as well. I had to power it off, then press A and it worked. Very weird. So if you had headset on, try this.

Yeah I pulled put the plug and did a hard reset and it worked. Thx

1 Like